Error: Unable to connect

Topics: Support Requests
Jul 17, 2013 at 2:32 PM
Hello all,

We are unable to test Client Center as with every release we have the same problem. We always receive the error "Unable to connect". We are running SCCM 2012 SP1 on a Windows Server 2012 and Windows 8 x64 and Windows 7 x86 as workstations.

Many thanks for any help
Alain
Coordinator
Jul 18, 2013 at 7:30 AM
Hi Alain

Have you checked the Requirements for Client Center:
  • Enable and Configure WinRM (Command: winrm quickconfig).
  • Test if you can connect the target computer with powershell remoting (Open Powershell and enter:
    Enter-PSSession computername)
  • You must have local Admin rights on you target systems.
Are you able to connect a client by using Powershell remoting ?
Jul 18, 2013 at 7:49 AM
Hi rzander,

I've tried your command, but still unable to connet to "localhost". For your information, the Firewall service is set to automatic, but it is turned off, so no blocking is done on the machine. I should at least be able to my machine... ? No ?
WinRM has been updated to receive requests.
WinRM service type changed successfully.
WinRM service started.
WSManFault
    Message
        ProviderFault
            WSManFault
                Message = WinRM firewall exception will not work since on
ne is set to Public. Change the network connection type to either Domain

Error number:  -2144108183 0x80338169
WinRM firewall exception will not work since one of the network connectio
e the network connection type to either Domain or Private and try again.
Coordinator
Jul 18, 2013 at 8:12 AM
Your Connection type is public ! are you member of a Domain ? -> change the network connection type to Domain !

What is the result if you open Powershell and enter:
Enter-PSSession localhost

2nd, are you able to connect a remote device (e.g PC1)
Enter-PSSession PC1
Jul 18, 2013 at 8:18 AM
Yes I know that it sais "Public" but I'm in a domain, please view the printscreen :) Eh... how can I add an attachement?

The Powershell output:
PS C:\windows\system32> Enter-PSSession localhost
Enter-PSSession : Connecting to remote server localhost failed with the following error message : The client cannot
connect to the destination specified in the request. Verify that the service on the destination is running and is
accepting requests. Consult the logs and documentation for the WS-Management service running on the destination, most
commonly IIS or WinRM. If the destination is the WinRM service, run the following command on the destination to
analyze and configure the WinRM service: "winrm quickconfig". For more information, see the
about_Remote_Troubleshooting Help topic.
At line:1 char:1
+ Enter-PSSession localhost
+ ~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : InvalidArgument: (localhost:String) [Enter-PSSession], PSRemotingTransportException
    + FullyQualifiedErrorId : CreateRemoteRunspaceFailed
Coordinator
Jul 18, 2013 at 8:48 AM
Is the Firewall turned off for all netwok types or only for "Domain" ? do you have additional Network Adapters active where the Network type is "public"... ?

So at least we know that WinRM is not configured propperly...
Aug 20, 2013 at 12:24 PM
Hey, im having the same problem.

After running the WinRM quickconfig both computers say they are configured.

Enter-pssession;
PS C:\Windows\system32> enter-pssession lt34108
enter-pssession : Connecting to remote server lt34108 failed with the following error message : The connection to the s
pecified remote host was refused. Verify that the WS-Management service is running on the remote host and configured to
listen for requests on the correct port and HTTP URL. For more information, see the about_Remote_Troubleshooting Help
topic.
At line:1 char:1
  • enter-pssession lt34108
  • ~~~~~~~~~~~~~~~~~~~~~~~
    • CategoryInfo : InvalidArgument: (lt34108:String) [Enter-PSSession], PSRemotingTransportException
    • FullyQualifiedErrorId : CreateRemoteRunspaceFailed```
PS C:\Windows\system32> enter-pssession localhost
enter-pssession : Connecting to remote server localhost failed with the following error message : Ingen tilgang. For mo
re information, see the about_Remote_Troubleshooting Help topic.
At line:1 char:1
  • enter-pssession localhost
  • ~~~~~~~~~~~~~~~~~~~~~~~~~
    • CategoryInfo : InvalidArgument: (localhost:String) [Enter-PSSession], PSRemotingTransportException
    • FullyQualifiedErrorId : CreateRemoteRunspaceFailed
There is no network restrictions between these two computers.

Any idea what i can do about this?

It connects to the server, but not to a computer.
Coordinator
Aug 20, 2013 at 1:05 PM
Google told me that "Ingen tilgang" means Access denied.... And Access denied means that you do not have enough rights :-). You have to run powershell as "Administrator"...

Are you able to connect port 5985 and your target device by using telnet ? -> telnet lt34108 5985
Aug 20, 2013 at 8:02 PM
Edited Aug 20, 2013 at 8:03 PM
Sorry about that, should probably parafraced the error in english instead..
The strange part is that i did run powershel as admin..


Ill try telnet first thing tomorrow morning! :)
Aug 21, 2013 at 10:03 AM
Edited Aug 21, 2013 at 10:07 AM
Had some trails and errors with the telnet and powershell stuff today.


This command in Powershell made the client center connect;
Set-Item WSMan:\localhost\Client\TrustedHosts *

This needs to be done on both computers, probably needs to strip this down a bit to not allow everything.


Starting Powershell console (from the client center) gives me;
Enter-PSSession : Connecting to remote server 10.14.1.94 failed with the following error message : The WinRM client cannot process the request. Default authentication may be used with an IP address under the following conditions: the transport is HTTPS or the destination is in the TrustedHosts list, and explicit credentials are provided. Use winrm.cmd to configure TrustedHosts. Note that computers in the TrustedHosts list might not be authenticated. For more information on how to set TrustedHosts run the following command: winrm help config. For more information, see the about_Remote_Troubleshooting Help topic.
At line:1 char:1
  • Enter-PSSession 10.14.1.94 -Port 5985
  • ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    • CategoryInfo : InvalidArgument: (10.14.1.94:String) [Enter-PSSe
      ssion], PSRemotingTransportException
    • FullyQualifiedErrorId : CreateRemoteRunspaceFailed
Coordinator
Apr 7, 2014 at 1:14 PM
Sherry Kissinger has created a Settings Baseline to Monitor WinRM Settings: http://mnscug.org/blogs/sherry-kissinger/307-compliance-setting-to-enable-winrm-updated

Connection IP addresses requires additional Settings; read http://technet.microsoft.com/en-us/library/dd347642.aspx (section: HOW TO USE AN IP ADDRESS IN A REMOTE COMMAND) ; Client Center Versions after March 10. will bring a Warning if you try to connect an IP without providing Usernam and Password...